[Fontinst] recordtransforms lehmann

Ralf Stubner ralf.stubner at web.de
Sun Oct 23 21:26:49 CEST 2005

On Sat, Oct 22, 2005 at 13:43 +0200, Wenger-Lehrmittel at t-online.de wrote:
> Since many days I try to install a font in Latex on Linux (Suse).

Which version? Which TeX distribution?

> First I tried an afm and pfb (Font: RoBirke) its not working so I tried 

What problem did you have with the Type1 fonts?

> a ttf. First I transformed the ttf to type1 with ttf2pt1 -a -b ok.
> Then I used the Lehmann-guide:
> I renamed the font to frb8a.afm and frb8a.pfb

Are these the original, or the converted Type1 fonts?

> then I wrote the following file withe the name frb-drv.tex:
>   \input fontinst.sty
> \recordtransforms{frb-rec.tex}
> \latinfamily{frb}{}
> \endrecordtransforms
> \bye

The version of Philipp Lehman's guide I have here reads:

\input fontinst.sty

Why did you omit the second line?

> It wrots no frb-rec.tex but a frb-drv.dvi it contains only frb-rec.tex 
> as text.
> The frb-drv.log contains errors:
>  This is the log: sorry it is long
> peter
> This is TeX, Version 3.14159 (Web2C 7.4.5) (format=tex 2005.4.1)  22 OCT 
> 2005 12:22

This looks like teTeX 2.0.2 which has a rather old fontinst.

> ! Undefined control sequence.
> l.2 \recordtransforms
>                      {frb-rec.tex}
> The control sequence at the end of the top line
> of your error message was never \def'ed. If you have
> misspelled it (e.g., `\hobx'), type `I' and the correct
> spelling (e.g., `I\hbox'). Otherwise just continue,
> and I'll forget about whatever was undefined.

This is the consequence of a to old fontinst. Either update to a more
recent fontinst version, or remove \recordtransforms{frb-rec.tex} and
\endrecordtransforms from your driver file. 

I am not sure if this will solve the rest of your errors, but it is a
necessary first step.


More information about the fontinst mailing list