[metapost] Difference between "mpost file.mp" and "mpost ./file.mp"

Dan Luecking luecking at uark.edu
Thu Sep 9 20:47:17 CEST 2010

At 07:07 AM 9/9/2010, you wrote:
>Dear list
>When using the TEX module to typeset labels in a for loop, I
>accidentally discovered that there is a difference between calling
>mpost as "mpost -tex=latex file.mp" and "mpost -tex=latex
>./file.mp". In the former case, the labels come out as expected,
>whereas in the latter, I only get 0's. Is this documented or expected?
>I can see that the latter produces more output to the terminal as
>well, although I can't figure out what it means.

I get the same result (MetaPost 1.211 from TeXLive 2010 pretest).

Perhaps it is a function of security settings. It would appear that
mpost is not overwriting mptextmp.mpx. Thus only the first one that
was created (containing code to produce 0) is used repeatedly.

Some programs will not overwrite "dot files". With TeX this is
controlled by the variable openout_any in texmf.cnf. I tried
changing it from p (paranoid) to a (any) but that didn't help this

Perhaps there is simply a bug in mpost in the handling of dot files.


Daniel H. Luecking
Department of Mathematical Sciences
Fayetteville, Arkansas

More information about the metapost mailing list