[tex-k] xdvi with gs 7.0.4, and a test for making good pdf

M. Shell mshell@ece.gatech.edu
Wed, 20 Feb 2002 03:52:18 -0500

 Looks like I spoke too quickly. You're right Reinhard!
 I finally got a chance to read the full thread in the pdftex list
 archive. I didn't realize that you had already run some experiments
 on this.
 So, I ran some more tests. I took testflow.ps and then converted it
 to two pdf files using GS 7.03. The first pdf file was converted using:
  -dCompatibilityLevel=1.2 -dMAxSubsetPct=100 -dSubsetFonts=true 
 Let's call the resultant file testpdf12.pdf
 The second pdf file was made with:
 -dCompatibilityLevel=1.3 -dMAxSubsetPct=100 -dSubsetFonts=true 

 Let's call this pdf file testpdf13.pdf
 Now, testpdf12.pdf will follow PDF V1.2 standards and 
 testpdf13.pdf will conform to PDF V1.3. Another difference
 is that testpdf13.pdf will have the standard base 14 fonts
 embedded and subsetted while testpdf12.pdf will not have
 the standard fonts embedded (this is the way Ghostscript 
 7.03 does things and I don't know if it is possible get
 Ghostscript to make a PDF V1.2 with embedded standard fonts.)
 In testflow.tex there is a sentence used as a test:
 {\footnotesize The ``Problematic" little quotes.}

 Here is what happens when I print from various versions of
 Acrobat reader to an HP Laserjet II with an Adobe Level 1
 PostScript Cartridge. (I can create the same types of problems
 with a LaserJet 4si with Adobe Level 2 PostScript.)
 Under Linux Acrobat Reader 4.0.5:
 testpdf12.pdf: trailing quote hits the word "little". (wrong)
 testpdf13.pdf: (correct)
 Under Windows Acrobat Reader 5.0.1 and 5.0.5:
 testpdf12.pdf: leading quote hits the word "Problematic". (wrong)
 testpdf13.pdf: (correct)
 When I use gsview to look at the files, I can see the flaw
 the same way as rendered by Acrobat Reader 5.0.1 and 5.0.5.
 So, I guess I was wrong. It is not Acrobat reader that is 
 altering the metrics, somehow Ghostscript has a problem
 with PDF V1.2. I tried Ghostscript 7.0.4 with the same
 result. Dang, I was hoping 7.0.3 was clean.
 Incidentally, when printing on the LaserJet II, I noticed that
 the lower case z looked like Times New Roman (straight bottom).
 However, when I did a font printout on the printer, the
 Times Roman Italic lower case z *does* look like that of 
 Times New Roman - with a straight bottom. The Times BoldItalic
 "z" looks like it is supposed to - with a curly bottom. 
 With the LaserJet 4si, both the Italic and BoldItalic types
 have the correct curly bottom. I guess this is another reason
 to embed the standard fonts (like the Kyocera example you
 Acrobat Reader may restore the correct fonts, but when
 printing to a PostScript printer it will do so by font name
 only - unless you embed the standard fonts, you'll get whatever
 Times Roman is in the printer. I haven't tried it with PCL


  Mike Shell