[tex-k] Re: tetex-extra and fmtutil

Frank Küster frank at debian.org
Mon Aug 16 18:51:29 CEST 2004

clone 265611 -1
retitle -1 conffiles in VARTEMXF are not found
forwarded -1 tex-k at mail.tug.org

Dear texk team,

I have an issue with kpathsea and cnf-Files. It may be a user error, but
I am not sure; at least some better documentation could be needed.

In our Debian packages of teTeX, we have recently included a VARTEXMF
directory in the TEXMF variable:

VARTEXMF = /var/lib/texmf

However, whereas e.g. texmf.cnf in /usr/share/texmf/web2c/ is found,
fmtutil.cnf and mktex.cnf in /var/lib/texmf/web2c/ are not. In an
attempt to resolve this, I have also added /var/lib/texmf to the
TEXMFCNF variable (without recompilation so far), and I still get:

frank at alhambra:~$ kpsewhich --expand-path='$TEXMFCNF'
frank at alhambra:~$ kpsewhich fmtutil.cnf
frank at alhambra:~$ kpsewhich --format cnf fmtutil.cnf
frank at alhambra:~$ ls /var/lib/texmf/web2c/fmtutil.cnf 
frank at alhambra:~$ ls -l /var/lib/texmf/web2c/fmtutil.cnf 
-rw-r--r--    1 root     root         3913 2004-08-16 17:40 /var/lib/texmf/web2c/fmtutil.cnf

So the file is there, and readable, but is not found. Is it only the
kpsewhich invocation? - I could imagine this, for the TeX format
creation works flawlessly. Previously, when the file was in
/usr/share/texmf/web2c it worked.

Can you tell us what we are doing wrong?

Regards, Frank
Frank Küster, Biozentrum der Univ. Basel
Abt. Biophysikalische Chemie

More information about the tex-k mailing list