[tex-k] (fwd) Bug#266718: dvips: Fails to properly include fontsused both in EPS and in document

Thomas Esser te at dbs.uni-hannover.de
Mon Oct 25 16:18:46 CEST 2004

> %%DocumentFonts: cmsy10 cmr10
>  /cmsy10 /cmsy10 def
>  /cmr10 /cmr10 def
> into
> %%DocumentFonts: CMSY10 CMR10
>  /cmsy10 /CMSY10 def
>  /cmr10 /CMR10 def

That misses the problem. mpost already generates the lines that you

Maybe, the following sample makes the bug more clear:


If I run this (latex test; dvips test -o), I only get the "-" and the 2
from fig.0. The 3 is omitted. If I change line 4 to 23, then I get both
numbers from fig.0. Even if I remove line 4 entirely, everything comes
out right.

I have no idea whether this is a known limitation of dvips or if this
is something that can/ought to be fixed. A possible fix might be to
automatically disable partial font downloading for fonts that are used
in graphics such as fig.0. Another fix (much harder, I guess) would be
to scan fig.0 for the characters which are actually needed.

> It seems ok in 5.94b (without -G1). Please try 5.94b.

Strange. I still get wrong results with "dvips(k) 5.94b" (with -G0 as
well as with -G1).


PS: for reference, here is fig.0 as generated by mpost:

%!PS-Adobe-3.0 EPSF-3.0
%%BoundingBox: -9 -4 9 4 
%%Creator: MetaPost
%%CreationDate: 2004.10.25:1615
%%Pages: 1
%%DocumentFonts: CMSY10 CMR10
 /cmsy10 /CMSY10 def
 /cmr10 /CMR10 def
/fshow {exch findfont exch scalefont setfont show}bind def
%%Page: 1 1
-8.8557 -2.7951 moveto
(\000) cmsy10 9.96265 fshow
-1.107 -2.7951 moveto
(25) cmr10 9.96265 fshow

More information about the tex-k mailing list