[tex-k] whitespace in updmap.cfg

moe12 at gmx.net moe12 at gmx.net
Thu Apr 13 05:10:06 CEST 2017

Hi Norbert

I am a bit confused now, but it looks like it does in fact not have
anything to do with the whitespace, but with the order in which I
probably did things, which seemed to solve the problem.

first I ran updmap without effect
then I might have tried mktexlsr, without effect
then I discovered the whitespace in updmap.cfg, deleted it, ran updmap
and it worked.

Now I wanted to reproduce the error and put some whitespace where it was
before. Somehow, I managed, that the error occurred again (by now, I am
not so sure, how I did that) i.e. eufm did not appear in either of


but neither running updmap nor updmap-sys had any effect on that, even
after removing the whitespace again. At some point I ran mktexlsr and
afterwards (not immediately though) I ran updmap and eufm appeared in
as it should.

Now I went to my other computer, which had the same problem, i.e. updmap
did not have an effect, but running mktexlsr and again updmap produced
eufm in pdftex.map. Is this behaviour expected, I mean that updmap only
works correctly after running mktexlsr? (I don't understand what is
going on in this whole process...)

Moreover, I noted, that running updmap from within
caused the following:

WARNING: updmap has found mismatched files!

The following files have been generated as listed above,
but will not be found because overriding files exist, listed below.
 pdftex.map: ./pdftex.map
 pdftex_dl14.map: ./pdftex_dl14.map
 pdftex_ndl14.map: ./pdftex_ndl14.map
(Run updmap --help for full documentation of updmap.)

and from within other folders it didn't. I have no idea, whether it had
at any point any influence...

I am sorry, that I raised the issue with the whitespace, which in the
end does not seem to cause any problem at all. However, it looks like
there is some problem somewhere. (Freshly installing a system and
breaking things that previously worked definately is a problem.) But I
have no clue, where to find it. I have another laptop, where I might
install Arch soon and I will see, if the problem still occurs.

Sorry for not being able to provide a lot of useful information.


More information about the tex-k mailing list