[metapost] problem with file database in mp.992

Taco Hoekwater taco at elvenkind.com
Fri Jan 12 16:48:00 CET 2007

Karel Horák wrote:
> When I wrote that it worked fine before doesn't mean that I am sure that 
> it was the same version of mp, it could happen that it was 0.901. What 
> is quite strange is that mp finds files in metatype subdirectory, but 
> still could not find mentioned file osy.mp even if I moved it into the 
> metatype subdirectory and called mktexlsr.

> I tried the debug option, you can check the result in attachment.

The debug info was a big help.

It looks like a problem with $SELFAUTOPARENT. Where is your mpost.exe
in relation to c:\TeXlive ? It should be part of the TeXLive tree if
it needs to find files in c:\TeXlive (if not, you have to change the
search paths so that they become absolute).

These are some of the suspicious lines:

> kdebug:hash_lookup(TEXMF) => {!!$TEXMFVAR,$TEXMFHOME,!!$TEXMFMAIN,!!$TEXMFLOCAL,
> kdebug:hash_lookup(TEXMFVAR) => $SELFAUTOPARENT/texmf-var
> kdebug:hash_lookup(TEXMFMAIN) => $SELFAUTOPARENT/texmf
> kdebug:hash_lookup(TEXMFLOCAL) => $SELFAUTOPARENT/texmf-local
> kdebug:hash_lookup(TEXMFDIST) => $SELFAUTOPARENT/texmf-dist

Best, Taco

More information about the metapost mailing list